Microsoft having issues with their authentication at the moment.
Incident Report for Millersville University
Resolved
Microsoft continues to list this on their status page but last updated it on Saturday October 19, 2019 2:09 PM. It has been working for Millersville University since Friday evening. After speaking with the help desk decided to close this alert.

Unable to access Microsoft 365 services using MFA
MO193431, Office 365 Portal, Last updated: October 19, 2019 2:09 PM
Start time: October 18, 2019 9:30 AM
Status
Restoring service
User impact
Users may have been unable to sign in to Microsoft 365 services when leveraging Multi-Factor Authentication (MFA).
Posted Oct 21, 2019 - 08:34 EDT
Update
While MFA appears to be working again. Microsoft still lists the incident as restoring service on their status page. We will continue to monitor.

Unable to access Microsoft 365 services using MFA
MO193431, Office 365 Portal, Last updated: October 18, 2019 9:30 PM
Start time: October 18, 2019 10:32 AM
Status
Restoring service
User impact
Users may be unable to sign in to Microsoft 365 services when leveraging Multi-Factor Authentication (MFA).
Posted Oct 18, 2019 - 23:11 EDT
Monitoring
We are continuing to monitor this issue from Microsoft.

Unable to access Microsoft 365 services using MFA
MO193431, Office 365 Portal, Last updated: October 18, 2019 1:00 PM
Posted Oct 18, 2019 - 13:12 EDT
Identified
Unable to access Microsoft 365 services
MO193431, Office 365 Portal, Last updated: October 18, 2019 11:18 AM
Start time: October 18, 2019 10:32 AM
Status
Service degradation
User impact
Users may be unable to sign in to Microsoft 365 services.
Posted Oct 18, 2019 - 11:20 EDT
Investigating
We know that MFA from Microsoft is affected.
Posted Oct 18, 2019 - 10:58 EDT
This incident affected: Email.