Call Center Issue
Incident Report for Millersville University
Resolved
No additional call center issues have been reported. The issue has been resolved
Posted May 24, 2017 - 15:56 EDT
Monitoring
The phone vendor has resolved the issue causing problems for the Financial Aid and Info Desk call centers. They will continue to monitor the call center systems to ensure that they remain stable.
Posted May 23, 2017 - 17:00 EDT
Investigating
We are investigating reports of an issue with the Financial Aid and Info Desk call centers. Incoming calls currently can not be received. Updates will be posted as they become available.
Posted May 23, 2017 - 15:46 EDT