MAX is Currently Unavailable
Incident Report for Millersville University
Resolved
Incident has been resolved and will continue to monitor.
Posted Jan 05, 2020 - 12:20 EST
Investigating
We have been notified that MAX is unavailable and we are working to identify and resolve the problem.
Posted Jan 05, 2020 - 11:44 EST
This incident affected: MAX.