Ware Center Network Issue
Incident Report for Millersville University
Resolved
Network connectivity has been restored for the Ware Center.
Posted May 16, 2017 - 11:06 EDT
Investigating
We are investigating reports of issues with network connectivity in the Ware Center . Updates will be posted as they become available.
Posted May 16, 2017 - 09:02 EDT