Voicemail is unavailable
Incident Report for Millersville University
Resolved
The voicemail issue has been resolved and can now be accessed.
Posted Jul 14, 2017 - 08:12 EDT
Investigating
Voicemail disconnects immediately when accessed. The issue has been reported to the University's telephone service provider, who is working on the problem.
Posted Jul 14, 2017 - 06:27 EDT