Web and Application Servers Unexpectedly Down
Incident Report for Millersville University
Resolved
All production applications and services have been restored.
Posted Nov 16, 2017 - 21:53 EST
Identified
Many different applications including; MU Website, Authentication, myVILLE, Banner, Degree Works
An issue with hosting has been resolved and services and applications are beginning to be restored.
Posted Nov 16, 2017 - 21:25 EST