Password Portal - Reset Password Link not working
Incident Report for Millersville University
Resolved
This incident has been resolved.
Posted Jan 06, 2020 - 16:11 EST
Update
We are continuing to work on a fix for this issue.
Posted Jan 06, 2020 - 15:55 EST
Identified
The "Change Password" link is working and use this is you know your old password. The "Reset Password" link is not working and currently being worked on with the vendor.
Posted Jan 06, 2020 - 15:55 EST