Email Issue
Incident Report for Millersville University
Resolved
E-mails from non-university email addresses are now successfully being delivered.
Posted 3 months ago. May 15, 2019 - 11:05 EDT
Investigating
We have identified that receipt of e-mails from non-university email addresses is currently being delayed. These messages are not lost, just delayed. Updates will be posted as they become available.
Posted 3 months ago. May 15, 2019 - 10:47 EDT
This incident affected: Email.