E-mail Issue
Incident Report for Millersville University
Resolved
This incident has been resolved.
Posted Jun 13, 2018 - 09:16 EDT
Investigating
We are investigating reports of issues connecting to Millersville email. Updates will be posted as they become available.
Posted Jun 13, 2018 - 09:10 EDT
This incident affected: Email.