Email Certificate Warning
Incident Report for Millersville University
Resolved
Mail is functioning normally.
Client certificates have been updated and deployed.
Posted about 1 month ago. May 17, 2019 - 11:41 EDT
Monitoring
Some users may be seeing a certificate warning for autodiscover.millersville.edu when you login this morning, Friday, May 17th. Please accept the new certificate by selecting yes. Any further questions, please contact the helpdesk @ 7777
Posted about 1 month ago. May 17, 2019 - 07:38 EDT
This incident affected: Email.