Network access to MU sites
Incident Report for Millersville University
Resolved
This incident has been resolved.
Posted Nov 18, 2022 - 09:48 EST
Update
We are continuing to investigate this issue.
Posted Nov 18, 2022 - 09:25 EST
Update
We are continuing to investigate this issue.
Posted Nov 18, 2022 - 09:22 EST
Investigating
We are investigating reports of issues with accessing the Millersville websites and Thin Clients on site and VPN users.

Updates will be posted as they become available.
Posted Nov 18, 2022 - 09:16 EST
This incident affected: Internet, VPN and Virtual Desktops (Staff Standard, VLab).