SchoolDude Login Issue
Incident Report for Millersville University
Resolved
This incident has been resolved.
Posted May 24, 2023 - 13:53 EDT
Monitoring
We have received reports that users are not able to access SchoolDude. Upon discussion with Facilities, it has been recommended that all users change their passwords in order to log into the software. Upon a reset, it will allow users to log in.
Posted May 11, 2023 - 14:47 EDT
This incident affected: Other Applications (Other Application).