Wired Network Outage
Incident Report for Millersville University
Resolved
Issue has been resolved
Posted Jul 28, 2021 - 08:08 EDT
Identified
Various campus buildings are currently experiencing wired network outages. IT had identified the problem and is working to implement a fix as quick as possible. WiFi is still available in all campus buildings.
Posted Jul 23, 2021 - 12:50 EDT
This incident affected: Internet.