Website Issue
Incident Report for Millersville University
Resolved
This incident has been resolved.
Posted Jun 01, 2020 - 09:10 EDT
Investigating
We are addressing an issue affecting access to web forms and missing data at some URLs on the Millersville website. Updates will be posted as they become available.
Posted Jun 01, 2020 - 08:29 EDT
This incident affected: WWW Website.