Partial Mobile App Outage
Incident Report for Millersville University
Resolved
All functionality has been restored to the mobile app for both iOS and android.
Posted Oct 09, 2018 - 07:58 EDT
Investigating
The mobile app is currently not working for Android users. iOS users are experiencing limited functionality.
Posted Oct 08, 2018 - 15:30 EDT
This incident affected: Other Applications (Mobile App).