MU Video Playback, Web Site Issues
Incident Report for Millersville University
Resolved
The Kaltura company resolved the issues with MU Video.
Posted Jan 23, 2023 - 14:41 EST
Identified
You may experience problems browsing the MU Video website or playing media from MU Video. Technicians at Kaltura, MU Video's, have identified the source of the problem and are working to resolve it.
Posted Jan 23, 2023 - 09:24 EST
This incident affected: MU Video (MU Video Media Playback, MU Video Web Site, MU Video Management Console).