Campus Wireless
Incident Report for Millersville University
Resolved
Service has been restored.
Posted Sep 27, 2020 - 17:54 EDT
Investigating
We are currently investigating this issue.
Posted Sep 27, 2020 - 15:37 EDT
This incident affected: Internet and Wireless.