Wireless Internet Issue
Incident Report for Millersville University
Resolved
Wireless authentication is available.
Posted Apr 17, 2020 - 16:41 EDT
Investigating
We are investigating reports of wireless authentication not being available.
Millersville network engineers are working to resolve the issue.
Posted Apr 17, 2020 - 13:37 EDT
This incident affected: Wireless.