D2L Brightspace Issue
Incident Report for Millersville University
Resolved
This incident has been resolved by removing the Course Overview widget from the default course homepage.
Posted Nov 17, 2020 - 14:22 EST
Monitoring
We removed the Course Overview widget from the default course homepage as a temporary measure to fix the page loading problem. Developers at the D2L company are working on a revised Course Overview widget.
Posted Nov 13, 2020 - 16:29 EST
Investigating
We are investigating reports of an issue with D2L Brightspace. Course homepage widgets are sometimes failing to load their content. Refreshing or reloading the page usually helps.
Updates will be posted as they become available.
Posted Nov 12, 2020 - 10:14 EST
This incident affected: D2L Brightspace & Related Services (D2L Brightspace).