Issue with out outgoing email over the weekend
Incident Report for Millersville University
Resolved
This incident has been resolved.
Posted Jul 07, 2020 - 10:26 EDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Jul 06, 2020 - 09:31 EDT
Identified
The issue has been identified and a fix is being implemented.
Posted Jul 06, 2020 - 09:28 EDT
Investigating
We are currently investigating an issue with outgoing email over the weekend. If someone outside of the university reports not receiving an email that you know you sent. Please do not re-send, at this time. We will keep everyone updated as we work through the issue.
Posted Jul 06, 2020 - 09:16 EDT
This incident affected: Email.