VPN connectivity
Incident Report for Millersville University
Resolved
All VPN functionality has been restored.
Posted May 19, 2022 - 11:58 EDT
Investigating
Some VPN Clients are experiencing an issue with posturing. IT is working to identify the issue.
Posted May 19, 2022 - 08:04 EDT
This incident affected: VPN.