Website Issue
Incident Report for Millersville University
Resolved
This incident has been resolved.
Posted Aug 09, 2019 - 11:43 EDT
Investigating
We are addressing an issue affecting access to web forms and some URLs on the Millersville website. Updates will be posted as they become available.
Posted Aug 09, 2019 - 10:05 EDT
This incident affected: WWW Website.