Campus Wireless Network
Incident Report for Millersville University
Resolved
The campus wireless network maintenance is complete and users may should not experience any more interruptions of service.
Posted May 26, 2017 - 09:55 EDT
Investigating
The campus wireless network maintenance is taking longer than expected and users may experience brief interruptions of service throughout the morning.
Posted May 26, 2017 - 08:20 EDT