Info Desk Call Center Issue
Incident Report for Millersville University
Resolved
Telephone services have been restored for all call centers on campus including the Info Desk, IT Help Desk, Financial Aid, Admissions, and Registrar.
Posted Jul 13, 2017 - 14:11 EDT
Update
All call centers on campus including the Info Desk, IT Help Desk, Financial Aid, Admissions, and Registrar are being affected.
Posted Jul 13, 2017 - 09:28 EDT
Investigating
We are investigating reports of issues with the Info Desk Call Center. It is reported that incoming callers cannot hear the Call Center representatives. Updates will be posted as they become available.
Posted Jul 13, 2017 - 08:32 EDT