Email Delivery Delays
Incident Report for Millersville University
Resolved
All delayed emails have now been delivered.

For questions about this or any other IT service please contact the MU Help Desk, at help@millersville.edu or 717-871-7777.
Posted Sep 10, 2018 - 13:54 EDT
Monitoring
An issue was discovered where Listserv was accepting and queuing emails, however email delivery was being delayed. This incident has been resolved. All outgoing email will be delayed and delivered over the next couple of hours. The Systems Team will be monitoring the email queue until all delayed messages are successfully delivered.

For questions about this or any other IT service please contact the MU Help Desk, at help@millersville.edu or 717-871-7777.
Posted Sep 10, 2018 - 09:22 EDT
This incident affected: Email.