Telephones outage
Incident Report for Millersville University
Resolved
Multiple fiber breaks caused by extreme weather have been repaired. Phone services to campus have been restored.
Posted Aug 11, 2018 - 22:57 EDT
Identified
Due to carrier outage no calls can be made to or from campus. Incoming calls will go to voicemail. The University's telephone service provider is working with the carrier to resolve the issue.
Posted Aug 11, 2018 - 14:43 EDT
This incident affected: Phones & Voicemail.