www Intermittent Issues
Incident Report for Millersville University
Resolved
This incident has been resolved.
Posted Apr 25, 2024 - 14:43 EDT
Monitoring
Changes have been implemented and we are monitoring the results.
Posted Apr 24, 2024 - 11:03 EDT
Investigating
IT is aware of issues on www and is currently investigating the problem.
Posted Apr 24, 2024 - 10:15 EDT
This incident affected: WWW Website.