There is an increased amount of Spam today
Incident Report for Millersville University
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Jan 13, 2020 - 13:24 EST
Investigating
We are currently working to mitigate any outstanding spam emails. Thank you for your patience on this issue. You can always click the "Phish Alert Report" button on the top right corner of the message when it arrives if you believe the message is Spam.
Posted Jan 13, 2020 - 13:24 EST
This incident affects: Email.