Microsoft Teams Disruption
Incident Report for Millersville University
Resolved
Microsoft has implemented a fix for the Microsoft Teams disruptions. Team is now functioning as expected.
Posted Jan 30, 2024 - 09:46 EST
Monitoring
Microsoft put a number of fixes in place to address the Teams disruptions. Some users may still experience a delay in sending email to a Microsoft Teams channel. All other functionalities of Teams have been restored and Microsoft is continuing to monitor the situation.
Posted Jan 29, 2024 - 07:33 EST
Update
Microsoft is reporting a global issue affecting Teams. Users may experience multiple issues with their Microsoft Teams including being unable to launch teams, delays with sending and receiving messages, and pictures and videos not displaying. Microsoft is currently working to rectify the issues. Further updates will be provided as we receive them.
Posted Jan 26, 2024 - 13:40 EST
Update
We are continuing to work on a fix for this issue.
Posted Jan 26, 2024 - 13:40 EST
Identified
Microsoft is reporting a global issue affecting Teams. Users may experience multiple issues with their Microsoft Teams including being unable to launch teams, delays with sending and receiving messages, and pictures and videos not displaying. Microsoft is currently working to rectify the issues. Further updates will be provided as we receive them.
Posted Jan 26, 2024 - 13:36 EST
This incident affected: Other Applications (Microsoft Teams).