Admin By request on Macs Issue
Incident Report for Millersville University
Resolved
This incident has been resolved.
Posted Oct 06, 2022 - 09:31 EDT
Monitoring
A fix has been implemented and we are continue to look into this issue.
Posted Oct 04, 2022 - 15:52 EDT
Investigating
We are investigating reports of issues with Admin by Request popping up on Macs. Updates will be posted as they become available.
Posted Oct 04, 2022 - 15:48 EDT