Interfolio Issue

Incident Report for Millersville University

Investigating

The Office of the Provost has reported an Incident Report for Interfolio

Monitoring: User's inability to see their Interfolio case when using Chrome, Edge and Safari browsers

Investigating: Interfolio Engineering Team is working on a resolution.
Current workarounds include accessing Interfolio using FireFox browser or
Navigating to the tab titled “Overview” (right next to the tab titled "Packets")
Refreshing the web page
Navigating back to the “Packets” tab.
Posted Jan 29, 2026 - 10:18 EST
This incident affects: Other Applications (Other Application).