Sporadic Internet Connectivity Issues

Incident Report for Millersville University

Resolved

This incident has been resolved.
Posted Jul 22, 2026 - 10:47 EDT

Identified

The issue has been identified and a fix is being implemented.
Posted Jul 22, 2026 - 08:40 EDT

Investigating

Good Morning, We are currently experiencing small outages in our public internet connectivity resulting from work performed on the core fiber infrastructure located across the state of Pennsylvania. While all systems remain connected on campus, there are one to 2 minute drops occurring. We have contacted the GLOBALNoc and are awaiting further information.
Posted Jul 22, 2026 - 08:38 EDT
This incident affected: Internet.