Parking Portal TickeTrak Maintenance Extended by Vendor
Incident Report for Millersville University
Resolved
Parking Portal vendor has completed work and the system is once again available for use.
Posted Nov 12, 2024 - 16:12 EST
Identified
We are currently working with our vendor to restore services after an extended maintenance period
Posted Nov 11, 2024 - 19:52 EST
This incident affected: Other Applications (Other Application).