Trouble Logging into Scholarship Universe and Student Forms

Incident Report for Millersville University

Resolved

This incident has been resolved.
Posted Jul 02, 2025 - 10:51 EDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jul 02, 2025 - 10:14 EDT

Investigating

IT is aware of issues with Scholarship Universe and Student Forms and is currently investigating the problem with the software vendor.
Posted Jul 02, 2025 - 09:22 EDT
This incident affected: Other Applications (Other Application).