VillePrint Issue

Incident Report for Millersville University

Resolved

This incident has been resolved.
Posted 1 month ago. May 12, 2025 - 15:46 EDT

Investigating

We are investigating reports of issues with VillePrint. Updates will be posted as they become available.
Posted 1 month ago. May 08, 2025 - 13:02 EDT
This incident affected: Other Applications (Student Printing).