Argos Reporting Tool Issue

Incident Report for Millersville University

Monitoring

A fix has been implemented by the vendor. We have validated Argos is working and now closely monitoring.
Posted Jun 08, 2026 - 12:13 EDT

Investigating

Argos reporting tool is currently unresponsive, and we are reaching out to Ellucian. We will provide an update once Ellucian fixes the issue.
Posted Jun 08, 2026 - 10:55 EDT
This incident affects: Other Applications (MU Reporting/Argos).