Adobe Creative Cloud Applications
Incident Report for Millersville University
Resolved
SSL certificate issues have been resolved and users are now able to authenticate once again.
Posted Oct 22, 2019 - 09:46 EDT
Update
We are continuing to investigate this issue.
Posted Oct 21, 2019 - 16:25 EDT
Investigating
We are currently experiencing an issue with logging into Adobe Creative Cloud Applications. This may occur for either assigned license users as well as Shared Device License users.

MU IT technicians are aware of the issue and working with Adobe for a resolution.

Status will be updated when more details are available.
Posted Oct 21, 2019 - 16:22 EDT