PASSHE let us know that they believe the issue with the Travel Module has been corrected. The technical team terminated all processes on a specific server that they believe was causing the issue on Thursday evening. They've had no new reports of crashes or account lockouts since then. But we are being asked to reach out to them if we hear from anyone on our campus that is still experiencing issues. If you continue to have issues, please email Accounts.Payable@millersville.edu.
Posted Oct 06, 2025 - 08:45 EDT
Investigating
The travel module in Fiori Self-Service is experiencing issues. PASSHE is aware that some users are experiencing system crashes and account lockout messages. The PASSHE technical team is actively investigating and will share updates as more information becomes available.
Posted Oct 02, 2025 - 13:46 EDT
This incident affected: Other Applications (ESS/SAP/BI).