Issues Accessing millersville.edu URL
Incident Report for Millersville University
Resolved
www access has been restored for both www.millersville.edu and millersville.edu
Posted Aug 23, 2019 - 20:01 EDT
Identified
It was identified that users attempting to reach millersville.edu without the www are likely to receive an error in their browser. It is recommended to use www.millersville.edu. There is potential for interruptions to all users as this issue is resolved.
Posted Aug 23, 2019 - 14:49 EDT
This incident affected: WWW Website.