Millersville University Website is experiencing issues. We are currently working on the problem to resolve it as quickly as possible.
Incident Report for Millersville University
Resolved
Problem has been identified and fixed the problem that occurred. Websites have been tested and all is working as expected.
Posted Jan 27, 2020 - 09:15 EST
Investigating
We are currently investigating this issue.
Posted Jan 27, 2020 - 08:23 EST
This incident affected: WWW Website.