myVILLE Unavailable
Incident Report for Millersville University
Resolved
Application has been restored along with other applications that had a similar issue.
Posted Jan 19, 2020 - 14:46 EST
Investigating
We are currently working to restore myVILLE.
Posted Jan 19, 2020 - 13:25 EST
This incident affected: myVILLE.