Access Issues with MyDesktop and vLab

Incident Report for Millersville University

Resolved

A fix has been implemented, and we will continue to monitor connectivity.
Posted Jul 02, 2026 - 20:14 EDT

Investigating

We are currently investigating reports of users being unable to access MyDesktop (mydesktop.millersville.edu) and vLab (vlab.millersville.edu). Our team is actively working to identify the cause of the issue and restore service as quickly as possible.
We will provide updates here as more information becomes available.
Posted Jul 02, 2026 - 14:02 EDT
This incident affected: Virtual Desktops (Staff Standard, VLab).