Interfolio Authentication Unavailable

Incident Report for Millersville University

Resolved

This incident has been resolved.
Posted Oct 28, 2025 - 15:42 EDT

Investigating

Interfolio authentication is currently unavailable while we wait for the vendor to provide an update.
Posted Oct 25, 2025 - 23:25 EDT
This incident affected: Other Applications (Other Application).