Examity Issue
Incident Report for Millersville University
Resolved
The Examity company implemented a fix. This incident has been resolved.
Posted Feb 23, 2021 - 08:20 EST
Investigating
The Examity company are investigating reports that some students are unable to connect to the proctoring service. Updates will be posted as they become available.
Posted Feb 22, 2021 - 20:49 EST