Turnitin Issue
Incident Report for Millersville University
Resolved
Turnitin fixed the server issue that had prevented enabling Similarity Check or GradeMark. Please return to assignments and enable Turnitin where you could not before and resubmit to Turnitin any pending student submissions.
Posted Nov 01, 2024 - 08:18 EDT
Identified
Turnitin and D2L are working on a fix.
Posted Oct 31, 2024 - 12:48 EDT
Investigating
A problem with Turnitin prevents enabling Similarity Check or Online Grading for assignment folders. Turnitin are investigating this issue. D2L itself, and other tools integrated with it, are not affected.
Posted Oct 30, 2024 - 16:06 EDT
This incident affected: D2L Brightspace & Related Services (Turnitin Feedback Studio).