Student Printing Issues

Incident Report for Millersville University

Monitoring

A fix has been implemented for student printing, and we are monitoring the results.
Posted Jan 21, 2026 - 09:37 EST

Investigating

Some students are experiencing authentication failures and freezing at print release stations. We are investigating the issue and will provide updates as they become available.
Posted Jan 20, 2026 - 15:09 EST
This incident affects: Other Applications (Student Printing).