Outlook Loading Issue
Incident Report for Millersville University
Resolved
This incident has been resolved.
Posted Oct 14, 2024 - 10:19 EDT
Monitoring
Microsoft has indicated that a fix has been put in place however individuals will need to take the following action:
- Outlook client and app users should restart their client or app to apply our changes.

- Outlook on the web users should refresh their sessions. If that does not mitigate the issue, users are encouraged to clear their browser cache and refresh their Outlook on the web session.
Posted Oct 10, 2024 - 14:52 EDT
Investigating
Microsoft is investigating reports of issues with performance issues with Outlook client, Outlook web, and Outlook mobile apps. Updates will be posted as they become available.
Posted Oct 10, 2024 - 13:33 EDT
This incident affected: Other Applications (Other Application).