eTime Access Issue

Incident Report for Millersville University

Resolved

PASSHE has resolved the issue with eTime and full functionality has been restored.
Posted Feb 19, 2026 - 10:43 EST

Investigating

We are investigating reports of issues with accessing eTime. We have reached out to PASSHE for more information. Updates will be posted as they become available.
Posted Feb 18, 2026 - 09:41 EST
This incident affected: Other Applications (ESS/SAP/BI).