myVILLE Experiencing Intermittent Issues

Incident Report for Millersville University

Resolved

This incident has been resolved.
Posted Aug 27, 2025 - 14:31 EDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Aug 27, 2025 - 08:16 EDT

Investigating

We are investigating issues with myVILLE that some users are experiencing. Steps are being taken to route users to their applications through Logins page where possible.
Posted Aug 25, 2025 - 09:04 EDT
This incident affected: myVILLE.