D2L Document Previews Issue
Incident Report for Millersville University
Resolved
This incident has been resolved.
Posted Apr 24, 2020 - 12:32 EDT
Identified
Document previews are not displaying in D2L Brightspace. D2L are fully engaged and working to resolve the issue. Updates will be posted as they become available.
Posted Apr 24, 2020 - 07:32 EDT
This incident affected: D2L Brightspace & Related Services (D2L Brightspace).